Jump to content
hidski222

GE Tracker API question

Recommended Posts

Hello GT Forum,

I have been fiddling with the GT API for a bit now and I cannot seem to figure out what format the results I am getting from a search request are. I thought it was JSON at first but it looks so odd with all of the slashes. Following is the resulting string for the search query "twisted bow":

"{\"data\":[{\"itemId\":20997,\"name\":\"Twisted bow\",\"icon\":\"https:\\/\\/www.ge-tracker.com\\/assets\\/images\\/icons\\/20997.gif\",\"buyingQuantity\":4,\"sellingQuantity\":6,\"overall\":1195185244,\"buying\":1195429867,\"selling\":1195022162,\"buyLimit\":8,\"lowAlch\":0,\"highAlch\":0,\"updatedAt\":\"2018-09-09 09:30:31\",\"cachedUntil\":\"2018-09-09 09:40:31\",\"url\":\"https:\\/\\/www.ge-tracker.com\\/item\\/twisted-bow\"}],\"meta\":{\"count\":1,\"query\":\"twisted bow\"}}"

 

Next here is the resulting string from a search query that will yield multiple items, query "twisted":

"{\"data\":[{\"itemId\":20997,\"name\":\"Twisted bow\",\"icon\":\"https:\\/\\/www.ge-tracker.com\\/assets\\/images\\/icons\\/20997.gif\",\"buyingQuantity\":4,\"sellingQuantity\":6,\"overall\":1195185244,\"buying\":1195429867,\"selling\":1195022162,\"buyLimit\":8,\"lowAlch\":0,\"highAlch\":0,\"updatedAt\":\"2018-09-09 09:30:31\",\"cachedUntil\":\"2018-09-09 09:40:31\",\"url\":\"https:\\/\\/www.ge-tracker.com\\/item\\/twisted-bow\"},{\"itemId\":21000,\"name\":\"Twisted buckler\",\"icon\":\"https:\\/\\/www.ge-tracker.com\\/assets\\/images\\/icons\\/21000.gif\",\"buyingQuantity\":13,\"sellingQuantity\":7,\"overall\":9773361,\"buying\":9786153,\"selling\":9749605,\"buyLimit\":8,\"lowAlch\":0,\"highAlch\":0,\"updatedAt\":\"2018-09-09 09:30:31\",\"cachedUntil\":\"2018-09-09 09:40:31\",\"url\":\"https:\\/\\/www.ge-tracker.com\\/item\\/twisted-buckler\"}],\"meta\":{\"count\":2,\"query\":\"twisted\"}}"

I have tried using a C# JSON deserializer to put it in a class which has all of the attributes that we can see in the abovementioned objects, hoping it would work but no bueno. It also doesnt rly look like JSON with all the slashes. Dont think ive seen anything like this before. I couldnt find any API related stuffs on the forums so hope someone can help me out, kinda clueless now.

 

Thanks in advance.

Edited by hidski222
punctuation

Share this post


Link to post
Share on other sites

That looks like it's being escaped on your side as the slashes aren't in the actual JSON response :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Information

© GE Tracker 2016. RuneScape is a registered trademark of Jagex Ltd. This website is in no way affiliated with, authorized, maintained, sponsored or endorsed by Jagex Ltd or any of its affiliates or subsidiaries.

Terms & Conditions | Privacy Policy

GE Tracker Social Media

GE Tracker YouTube Partners

Powered By

Our prices and information are pulled from OSBuddy Exchange (Get PRO).
×
×
  • Create New...